An existing connection was forcibly closed by the remote host


#1

I’ve tried all the solutions i can get my hands on, i tried reinstalling, changing preferred server, restart my wifi, flush my DNS, and it still doesn’t work. This doesn’t only happen on one account as well, but both of my accounts get this same error whenever i tried to play. I can resolve it temporarily by using my phone’s mobile hotspot but the service quality is way worse than using wifi, I can’t even get in other servers like USEast for trading. Does anyone have a solution to this or have encountered something like this before? I’ve been contacting deca support over this past weekend but they haven’t been much help at all.


#2

I’ve had the exact same problem. The game kicked me while playing, and now it won’t allow me to enter any server.


#3

Ah, classic rotmg disconnections. These are very common issues and people kind of just ignore them by now with their frequency. If the issue is that you can’t reconnect right after the disconnect, you have to quit the game first, THEN restart it. However, if you restarted the game and still couldn’t reconnect, best thing to do is simply wait for ~15 minutes then restart. Very rarely, disconnects will keep you disconnected for much longer than usual, so you just have to wait longer. One last thing is that the game can disconnect you if you stand on certain tiles (or lack thereof). For example, if you’re in Deadwater Docks at the boss room and you’re sandwiched between the closing doors before boss, you’ll be disconnected. Similar thing happens in The Machine, where disappearing tiles purposefully disconnect you as an attack.