Can't turn on hardware acceleration


… also I don’t have flsah installed anywhere I can see it idk how the game runs lol


I would try opening Realm on browser ( Enable Flash on the site if it is not enabled already:

Once it’s enabled and the game is running on browser, right click the game and go to Settings...

It should look like this:


If that box isn’t checked, then check it and close the pop-up and see if hardware acceleration works on Steam now.

However, this is just a hopeful stab in the dark to see if there is something that can be done to fix it. Someone else was facing the same problem, but their computer was fairly old and we determined it was most likely the graphics card was too out-of-date to support Flash hardware acceleration. We couldn’t fix it in the end.


Mine is like a year old but it’s a trashy dell laptop so ¯_(x!x)_/¯


Nope doen’t work :confused: it started not working this morning…


Sounds like an OS/driver issue. I mean a trashy dell laptop should be fine. I used to use a 2008 MacBook, which had cheap Intel graphics and was otherwise slow, and hw accn worked on that (it died a couple of years ago).

So it should work on your laptop, but maybe something has changed recently in the OS which is interfering with it. I would see if there’s anything you can identify. If not just try a general cleanup – reboot it, perhaps defrag or run a virus scan, uninstall anything you don’t need.


I’ve done avast free virus smart scan came up nothing rebooted nothing used cccleaner to clean up used defraggler and still happening :disappointed_relieved:


Perhaps a recent OS update caused issues? Since you said you play on W10, and that tends to update from time to time (and things breaking because of it isn’t quite a rare occurrence).

Not sure if I would recommend reverting to a previous update though, as there’s more than just ability to access hardware acceleration on a Flash game that comes with those. Perhaps someone with more knowledge could help you weigh the pros and cons more, if it was an OS update that caused this.


Could this be a problem? It’s occoured before the problem though


Yes, that looks highly suspicious. It looks like some sort of malware. Why? As it is so vague about the problem it has identified. If Flash needs updating it pops up a dialog mentioning Flash. An OS normally identifies itself and describes updates it is doing. That looks designed to deceive you, as being so vague it allows you to think it will solve any problem you are having (possibly caused by it), so you download a ‘fix’ which is anything but. Especially if you are connected to the internet, so could download a fix from a reliable server like Adobe’s.


So how do I fix it?


I don’t know about that, it seems like a standard Windows 10 notification to me (which says quite a bit about W10…)

But still potentially possible that it’s malware.

To OP, I would recommend running a virus/malware scan using something like Malwarebytes. It wouldn’t hurt in any case.


Seems very unlikely it’s a proper Windows 10 updater. First why be vague about what is missing? Tell the user what is missing, as they might have some idea what caused it – a new piece of hardware or software perhaps.

But especially “we couldn’t connect to the update service”!?! Windows is owned by Microsoft. Servers are their business – Microsoft Azure in particular. They should have servers + backup servers for something as critical as OS updates, so you can always reach one if you are connected to the Internet. Some dodgy malware distributor though is likely to have flaky servers likely to go down/be taken down at a moment’s notice, so it will need to retry often.


Also happening with me, what can I do? besides running a malware scan?


I’m gonna do this and see if it works
EDIT: didnt work


Yep tried it too


Bump becoz I still need help
Also I ended up being able to update windows


Have you tried downloading flash again?


I play on steam




it is possible to convert a steam rotmg account into a flash one tutorial here
maybe just convert to flash