Debug while trying to buy gold


You don’t have to study it to know. You just have to be smart :joy:


You can’t just “switch to browser”… He is a white star and switching would mean restarting. I’m honestly tired of seeing you on these forums, that’s a personal problem though and I don’t have time for that on this thread.

@CptElite Have you tried doing what it says? Going to the properties and what not. I hardly use steam so this is a little out of my knowledge.


yes I have tried that. but it didn’t do anything, well. hopefully some staff-member sees this ‘‘bug’’ and fixes it. Thanks @Etahn


That’s weird. I hope it gets fixed soon for everyones sake. If this is a common problem then this is hurting how much money Deca makes and in turn hurting realm. Good luck, I guess.


when he says “lag” he refers primarily to input lag/browser lag/poor optimization… not necessarily net jitter.

chrome eats lots of RAM compared to steam, for instance. so people who play on Chrome would, on average, experience more input lag, crashes, etc. than people who play on steam.

and that is the case, which is why people often use flash projector or steam.


Further reading:

@CptElite Just search steam overlay in the search bar and see what happens :confused:

Srry dude


Dang, sorry I couldn’t help more but I’m not really sure how many Steam users there are around here. @Shatter doesn’t your ShatterBro account use Steam? Have you had this problem before?

Sadly most of the moderators on this thread probably aren’t experts (Doc is dead, BMJ is dead, only non-retired player is OtherBill really) so your best bet would be sending a support ticket to Deca.

I heard they get back decently fast; especially if you’re gonna drop some money and support the game lol.




I’ve tried it multiple times and its not working, I’ve restarted my game, reinstalled Realm (RotMG) and even went as far as re-installing steam. Nothing Happened sadly. Hopefully some kind of moderator sees this ‘‘thread’’ and takes it to the matters of own hands and fixes it for everybody that is having the same issue as me


What? I’ve barely been here


thats exactly the point…

hmm, srry, i cant help :stuck_out_tongue:


I get that too ;_;


No one here knows how to use steam xD


yes, no


The fix is: Have Steam overlay on, get on flash projector, open rotmg in projector and rightclick. Click settings, turn on hardware acceleration. Open RotMG on steam, go to nexus, go to settings and activate hardware acceleration under graphics. Now restart game and it should work.


i will try that as soon as I get home from school, thanks


[quote=“Edwardidk, post:8, topic:5498, full:true”]
Playing RoTMG on the browser is really laggy, so people try to avoid it.
[/quote]Other way around for me, only steam is laggy, browser is fine, projector is perfect.


I’m going to try update adobe later cause the proxy runs on adobe I think?


nevermind, fuck. now my game isnt even starting. KMS


So, from my knowledge of steam and how the overlay works. It may never work for you, as there is no consistent fix for the problem. Some people have contacted support and enabled play on browser with their steam account, but this doesn’t solve the problem, just skirts around it.

The Devs of the game do technically know about the problem, and so does the steam community. The problem has been around since I started playing (around 5 years ago). Some people using the “hardware acceleration” fix have their game work, others it makes it unusable.

The overall problem is that they don’t have an immediate solution. I’m sorry to say, but the fix isn’t happening any time soon (as far as I know…)


Stay on topic for one. Also I don’t recall, sorry.