Exalt disconnect loop


so everytime i try to join usw3(trading server, if you didnt know), but i keep getting put into a disconnect loop. basically, as soon as i enter the nexus, it says, “an existing connection was forcibly closed by the remote host”, forcing me to retry entering the nexus. unfortunately, i can’t even change servers because i cant connect to the nexus
i have restarted the game a few times and that doesn’t fix the problem
my wifi isnt the problem because it is very fast(according to the wifi speed test).
i suspect its usw3 causing the disconnect because i was able to connect to usw without issue, before i tried to connect to usw3

anyways, if you guys know how to fix this, that would be great

EDIT: problem solved, check orsome’s reply if you have this issue


changing exalt registry values to change the default server? idk ill go check


sooo, how do i do this


Open up the start menu, type ‘Run’

enter ‘regedit’

navigate to HKEY_CURRENT_USER -> Software -> DECA Live Operations GmbH -> RotMGExalt, and click on the Exalt folder

find the preferredServer key and double click on the text reading ‘preferredServer’

change the value of it to whatever other server you want to try, you can type in the text area on the right


click ‘OK’ and it should auto save

disclaimer i have no fucking clue if this will actually change the server but doing something similar worked when i couldnt connect to testing servers

edit: @Laserquest have you tried it yet


ye, im testing this right now

@Orsome it worked! thanks man.

still not sure why the dc’s happened, but as i said earlier, i suspect it is usw3


no way to back out of connecting to the server, nexus was full or smth so you couldn’t get into the game


the server wasnt/isnt full


:man_shrugging: exalt has a lot of random issues unsurprisingly, could be anything if nexus wasn’t full lmao


haha, well at least i can play the game now.


Hide your password.



oh fuck lmao thanks


You should probably change it now


yeah i have


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.