Exalt Technical Problems Troubleshooting Guide


If there’s any fix for a specific problem that worked for you, but that isn’t listed below, please share your solution (with as much detail as you can give as possible) in this thread.

I’ve tried to gather as many possible fixes as possible, but I know it isn’t a complete list. I also know some of these fixes aren’t quite accessible nor reasonable, but they are fixes nonetheless, and it’s just all we’ve been given to work with. It’s up to the devs to make things better.

And unfortunately, if you’ve tried all the fixes listed, but they don’t work to solve the problem you’re facing, there may be no known fix. That’s just how it is sometimes. If you do manage to figure out a fix though, please share it so others can know in the future!

Additionally, if there is any inaccuracy within the post (eg. a listed fact is wrong), please let me know and I will try my best to fix it. I’ve also tried my best to make the post as understandable as possible for everyone, even people who aren’t too knowledgeable with tech, so please let me know if anything needs to be explained more clearly.

Special thanks to @Tiffit for helping with testing, and @Zquidx for helping with giving me information as well as remaking an important imgur guide here when original was deleted.

There are a good amount of technical problems users run into when trying to play on the Exalt client. I thought it would be helpful to have an up-to-date guide/compilation of fixes players can reference when trying to fix those issues.
While there are similar guides people have created in the past, they are a bit out of date by now, and in some cases aren’t the most optimal solution to the problem (for example, exercising the “nuclear option” and deleting way more than needs to be deleted to fix the issue). There’s also a fair bit of misinformation floating around regarding fixes.
I’ll also be aiming for compiling fixes that actually helped to solve the issue, rather than just unfounded “well you should try [x] because that sounds like it would fix it”, to avoid clutter and wasting any time.
These fixes will be for Windows. I can technically also help with MacOSX but at the moment I’m too lazy to install Exalt on my laptop at all.

Introduction (you should read through this before reading rest of guide)
Here are some key “skills” you should know (and that will be referenced throughout the guide with underlined phrases).

Navigate to the Exalt registry folder

Please note that there is sensitive data contained in the registry, especially within the Exalt folder itself. Do NOT take screenshots of the regedit window, for your own safety. [1]
Please also exercise caution when deleting or modifying entries. If you aren’t exactly sure of what you’re doing, it honestly might be better to not touch anything. In the end RotMG is just a game and there are many other fun games out there that don’t require you to muck around in the registry to be able to play it.

Press Windows key + R, in the text box that comes up type in regedit and press OK. You may be prompted to allow the program to make changes to your device; answer Yes here.
(if you don’t have permission to modify the registry, which you might not have for example on school devices, you’re out of luck here)
Following the tree of folders on the left, head to Computer -> HKEY_CURRENT_USER -> SOFTWARE -> DECA Live Operations GmbH -> RotMGExalt.

From here you can edit or delete registry values, but do exercise caution. Once again, please don’t screenshot anything in here.
To edit a value, double click it, and you’ll be able to see some numbers or letters you can change.

To delete a value, right click it and select Delete.

Once you’ve made a change to the registry, you may need to restart the game if it is open for actual changes to the game itself to be applied.

[1] (technically, you can if you know what you’re taking a picture of doesn’t contain any sensitive data, but I prefer all-encompassing warnings rather than someone going “yep this doesn’t contain any sensitive data” and posting a screenshot and they were actually wrong and yea)

Switch Exalt to use your integrated graphics card

You only want to do this if you have an AMD graphics card, but an Intel CPU (which has integrated graphics card). In any other case, don’t do this.
If you want to double-check what your hardware is to make sure the above applies: right-click on your start menu, select Device Manager, click on Display adapters. You will want to make sure that one is an AMD card, and the other is something like “Intel HD Graphics” or similar. We will be switching Exalt to use the Intel card.
If you’re on a desktop PC and not a laptop, you should check that your monitor is plugged into your motherboard port rather than directly plugged into your GPU port (if you don’t know how to check this, don’t worry about it, but keep in mind if it does happen to be plugged into your GPU, the below steps won’t work)
Open up your display settings. I can get to it by right-clicking on my desktop background and selecting Display settings but you can also get to the Display tab from just opening up the Windows settings and navigating there.
Scroll to the very bottom and click on Graphics settings. On this next screen, click Browse, and navigate to the following:
Documents -> RealmOfTheMadGod -> Production -> select RotMG Exalt.exe
You’ll see RotMG Exalt show up now below the Browse button, click on it and click on the Options. Select the option that has the Intel card (this will most likely have the name “Power saving”) and then click Save.
If you want to have this apply to the public testing version of the game for whenever a PT is open, you will need to go through the steps above but instead of going to Production folder, go into Testing folder. Otherwise it will likely default to use your AMD card.

Switch server outside of the game
On Windows:
Use this program: https://github.com/tiffit/RotMGServerChanger
It is open-source (you can review the code yourself if you are concerned about safety) and I have personally tested it on my own machine.
Read through what is on that page to get the download link as well as instructions on how to run the program.
On Mac:
Open the Terminal app and you want to send the following, replacing <put a server name here of your choice> with an actual server name:
defaults write com.decagames.RealmOfTheMadGodExalt preferredServer -string <put a server name here of your choice>
Example: defaults write com.decagames.RealmOfTheMadGodExalt preferredServer -string USWest2
This should work but let me know if there are any issues, I have not tested it myself so there may be some slight errors potentially.

Now, let’s move on to (hopefully) getting your problem fixed.

Part I (major problems impacting accessing and playing the game)

"Build not exist in the current location. You need to download build again"
The launcher is unable to access the game’s files (which it should have downloaded to C:\Users\[your Windows user account name here]\Documents\RealmOfTheMadGod)


  1. If a public testing session is not open, make sure you’re on Production (in the top right of the launcher) and that you’re not on Testing. Trying to download a testing build when there is no public testing session active is one way you encounter this error.
  2. The obvious “turn it off and on again” equivalent, try Remove Build in the launcher (click the cogwheel in the top right and select Remove Build) and attempt to re-download the build again. It may be as simple as a file not properly transferring or something, and it’s best to do a quick and simple check before moving on to more drastic fixes that take longer.
  3. If you have an antivirus on your PC that runs in the background (for example: Avast, Norton, McAfee), and you don’t see the files properly appearing in Production folder: Disable your antivirus temporarily, and try downloading the build again.
  4. Go to the aforementioned directory (C:\Users\[your Windows user account name here]\Documents\RealmOfTheMadGod) and enter the Production or Testing folder depending on if you want to fix it for the main game or for a public testing session.
    Right-click the RotMG Exalt.exe file and select Properties. Go into the Compatibility tab and make sure that Run this program as an administrator is not checked.

    If there is already no checkmark in that box then it’s good, if there is a checkmark in that box remove it and click Apply.
  5. You should especially try this fix if your Windows user account has non-Latin characters (examples include: ü, é, ñ): Create a new Windows user account that just uses standard Latin/English characters as its name (eg: “cat”, “rotmg”, “h”). Log in to that account, install and run the Exalt launcher there, and see if you are able to play the game. (Yes, this is an unwieldy and potentially annoying fix).

I accidentally bound left-click to [key] and I can’t access the options menu to change it (or binding any key in such a way that you’re unable to fix it via the options menu)
Navigate to the Exalt registry folder. The registry entries should be organized alphabetically; locate the registry entries starting with Key. They should have somewhat informative names on what they do (for example, Key.UseSpecialAbility_[some irrelevant stuff here]).
Ideally, if you can identify what you accidentally bound and want to unbind, you can go through and find the corresponding name. When you’ve found it, you can simply delete that entry, and it will reset the keybind to the default.
If you can’t figure out which one corresponds to the keybind you want to remove, you can delete all Exalt registry entries starting with Key., but this has the unfortunate side effect of setting all your keybinds to default (since you’re getting rid of all the custom keybinds you set)

Exalt opens in an unplayable resolution (3 pixels by 30 pixels wide)

  1. Open up Task Manager (one way to do this is to right-click on your taskbar, and select Task Manager). From here, click on the > arrow to the left of RotMGExalt. This will make another row of RotMGExalt appear below it, right click on this RotMGExalt and select “Maximize”.
    The game will still look pretty scuffed, but from here you should be able to press Escape to bring up the Options menu. You should now be able to set a proper resolution for the game, and it should save the resolution you picked properly in the future.
  2. Try this if the above didn’t work: Navigate to the Exalt registry folder. The registry entries should be organized alphabetically; locate the registry entries starting with Screenmanager. You will need to delete all of those entries. The game should now start in default resolution next time you start up the game. (needs further testing to see if we can narrow down which registry entries exactly are bugged and avoid removing excess entries. My theory is that simply changing the bugged widths and heights to something more sane like 800x600 in the registry should be sufficient to solve the problem and deleting entries is not necessary, if anyone has tried this and gotten success please let me know)

Severe input lag when playing on Exalt

  1. Try switching from playing in windowed mode to instead playing in fullscreen mode. Even if you have the game in a resolution smaller than your monitor’s, fullscreen mode should still work.
  2. Try switching the monitor you’re playing the game in if you have more than one monitor, or changing your monitor settings. Specifically, even if you only have one monitor, changing your display settings from “PC only” to “extend” or “duplicate” or “second screen only” could fix input lag. (thanks to @Unicorn for this info)

Trees (such as the decorative trees in Haunted Cemetery and in Candyland Hunting Grounds) severely lag Exalt
As far as I can see, all reports of this are from people using AMD GPUs (graphics card). This tends to happen on AMD GPUs, as well as maybe older GPUs though this isn’t confirmed.
Fix: If you have an Intel CPU, switch Exalt to use your integrated graphics card. This should fix the tree lag.

If you have an AMD CPU so above fix does not apply, or you have tried the fix above and there is still performance issue: Unfortunately, there’s no known fix other than to play on a computer with a GPU that works well with this game, which I know is not an accessible fix in many cases.

Severe lag with Exalt in general
Fix: It’s honestly most likely that your computer is too weak to run Exalt, and changing around the settings likely won’t do too much. You can still try changing these settings, just to try and squeeze out as much performance as possible, though I feel it likely won’t have significant effect:
(These are all in the Video tab of the Options)

  • Lower the Resolution (smallest possible is 800x600)
  • Use Fullscreen mode rather than Windowed mode (this still works even if on 800x600 resolution)
  • Turn as many settings in the Quality subcategory off as possible (and set Ally Shoot to Hide All). Some of these you may want on for quality of life (eg. some like having text bubbles on), but you can try turning as many of these off as possible.
  • Not an in-game thing, but if you’re playing on a laptop, ensure that your laptop is not low on battery, and turn off any “power-saving” modes that throttle the CPU/GPU. Additionally, regardless of whether you’re playing on a laptop or desktop, try to close as many other programs running on your PC as possible, even ones running in the background.

If even after that, the game still does not run well enough to where you consider it playable, I’m going to have to be the bearer of bad news and tell you that there’s really no fix other than hoping that game performance improves in future updates, or playing on a computer with better hardware.

Exalt crashes/stops responding on loading screen
This manifests itself as the following:

  • You’ll be in the loading screen for Exalt, or about to load into the Nexus (and can maybe hear the first few notes of music playing), when the game will crash.
  • You may see a small window pop up, potentially very briefly. This window will have an image of Oryx’s blocky head next to a red exclamation mark, as well as a green progress bar below it (aka the Unity crash window).

From examination of error logs taken after such a crash occurred, my leading theory is that this is an incompatibility with your GPU’s drivers and DX11 (which appears to be what Exalt uses). This seems to be an AMD issue, though I’m not certain that Nvidia users may not also be running into issues (if you are, please report so I know, it may be the same issue or a different issue).
Either way, the game crashes while it’s in the process of initializing shaders.
Tentative fix #1, that needs testing but I am a little more confident on:
If you have an Intel CPU, please switch Exalt to use your integrated graphics card and see if the game now can launch. The reason for the crash should no longer be an issue with using the integrated card hopefully, please report back if it still crashes or if it stops crashing, just so I know if this works as a fix or not.

Tentative fix #2, that needs testing:
If anyone is able to, I would like if they could test this. Note the current version of your AMD GPU’s drivers. Try to update to the most recent driver version available (just to cover all our bases), and see if the game works. If it still doesn’t work, then try downgrading to the 18.4.1 version of the driver from here, and see if the game works. You can also try other versions of the driver as well. If at any point the game starts working properly, it would be helpful if you could share which version(s) of the driver they failed to work for, and which version(s) they worked for. And obviously, since you’ve noted your current version, you can update back to that version or most recent version if you ever need to.
Fix for now:

  1. For now, you’ll almost certainly need to play Exalt on a different machine where this problem does not occur.

Exalt is stuck in an infinite loading screen
You’ll see that the loading animation is still playing on this screen, but it’ll play infinitely, and you won’t seem to ever get into game. Do note that you should be able to still quit the game by pressing Escape and selecting the Quit button that appears.
Now, to try and actually fix the issue so you can get into the game, not just leave it:

  1. If you’re just trying to launch the game by just double-clicking the exe in C:\Users\[your Windows user account name here]\Documents\RealmOfTheMadGod\[Production or Testing])… don’t do that. That’s not how you open up the game. Just use the launcher to run the game, or refer to Fix 4 in “Build not exist” in this guide if you really absolutely hate the launcher for some reason.
  2. Try waiting for over 10 minutes without opening up the game at all, before trying again and seeing if it works then. The “10 minute dc” is a known occurrence you may run into sometimes; it’s one of the game’s anti-abuse/exploit mechanisms mistakenly kicking in. If you’re still running into an infinite loading screen after this, try moving on to one of the below fixes.
  3. Check if the server you believe you’re trying to connect to is down (some ways you can check include seeing if RealmEye notes that it can’t connect to specific servers at the top of the page, or just hanging around RotMG Discords/chat groups where such an issue may be mentioned). If you believe you are trying to connect to a server that is down, you will need to switch server outside of the game.

Final note: Rarely, it seems like the game may not properly show any message to indicate if a user is banned, and instead just gives them an infinite loading screen when they try to log in. I put this at the bottom here as a final possible explanation, albeit very unlikely (unless you’ve been naughty), as I feel it’s much more likely you’re running into a technical issue with the game.

"There was a problem downloading build. Please remove the build manually and try again."
Exalt Client crashing on start up
Build Does Not Exist In Current Location.....Help
exalt update glitch
I log into game but I see black screen
Build Does Not Exist In Current Location.....Help
ROTMG Exalt Is Tripping My Antivirus Software now
RotMGExalt quit unexpectedly

Part II (minor technical problems that cause issues or inconveniences)

Some game settings need to be toggled twice every time the game is started up to work properly (eg. Enemy Damage Text needs to be turned on then off again for it to properly be off)
Fix: There is a fix for some if not all of these bugged settings.
Navigate to the Exalt registry folder. You’ll need to find the setting corresponding to the one that’s bugged in-game.
For reference, the ones that are known to be bugged along with their corresponding registry entry name are:
Enemy Damage Text -> disableEnemyDamageText
(this list may be incomplete; so far from testing, I’ve only been able to replicate that Enemy Damage Text is bugged, please let me know of any others!)
Delete the registry entry corresponding to that bugged setting. The game will now use the default, which is hopefully what you would like the game to do. If the default is the opposite of what you wanted, unfortunately there is no further fix. You will have to wait for Deca to fix the game.
Also, don’t touch that bugged setting in the Options menu, if you change it in any way after the fix it will be broken again and you will have to redo the fix.


Thanks textbook, very helpful :slight_smile:

One other thing I thought of is changing servers through regedit if the server you are on is down, since there is no option to do so before loading in the game.

Also when I first started using exalt beta, I had very noticeable input lag. This was fixed by using a second monitor and I’m still not sure why it happens (in fact changing my display settings from “PC only” to either “extend” OR “duplicate” OR “second screen only”, even without having a second monitor plugged in, works). I’ve also heard of others complain about input lag but presumably it got fixed (or they just gave up and accepted the delay lol), can only think of tharms ATM I can ask if/how he fixed it


Very good unity FAQ post, many people post about those issues. You could make this a wiki post?

I have an Nvidia GT 520 and I have this problem; also happens with drunk effect. Pretty frustrating.

It’s an old graphics card but I didn’t have this issue on flash or similar better optimized unity games with better graphics so deca can surely optimize this better.


forgot their requirements mentioned this, could lead to a fix maybe if anyone has amd


The problem manifests itself as being stuck in an infinite loading screen when you’re trying to connect to a server that’s down, right? Just want to make sure this is the case.

The infinite loading screen is tricky since it seems like a multitude of problems can cause it, but I do want to try and tackle it if possible. I’m updating this post semi-regularly, whenever I have time.

One thing I have looked into, but came up with no leads so far, was trying to figure out what causes the “Problem with load init data!” issue which some people run into. If anyone’s had this problem but managed to fix it, or knows anyone who had the problem but managed to fix it, please let me know, and I can try to add it to the guide.


Yes, exactly that.


I need help on using the launcher in documents folder beacuse i get build does not exist constantly


do you have avast


Hi! The imgur album link on how to set up bypassing the launcher wasn’t working earlier today, but I’ve fixed that now (for reference, it’s this link: https://imgur.com/a/1afO1X3). I assume you’re looking to set up the shortcut to bypass the launcher because the launcher is giving you the error.

If you have any questions or could mention any area in the guide where you get stuck on, feel free to ask here and I or @Zquidx could respond (pinging him since he’ll also likely appreciate feedback on improving the guide if there are any unclear areas) and hopefully help you through the process.
Just let me know where you are having the problem with setting it up.


" Severe lag with Exalt in general
Fix: It’s honestly most likely that your computer is too weak to run Exalt"

  • System requirements for ROTMG:
  • OS: Windows XP or later

  • Processor: 2.33GHz or faster x86-compatible

  • Memory: 1 GB RAM

  • Hard Drive: 100 MB HD space

My Specs:

  • OS: Windows 10

  • Processor: i5-5200U / 2.19GHz

  • Memory: 4.00 GB RAM

I could run ROTMG perfectly fine until exalt which was supposed to “Improve performance” ended up leaving me in the dust. I’m disappointed, I’ve supported this game since around 2011 and my time here will be ending thanks to DECA’s inability to support lower end machines (why are there so many useless effects, when I turn things off I expect it to not look good and not lag instead I’m met with an average looking game with lag and useless particles & animations everywhere also who needs status effects above anyone but themselves?).


I’ve seen more than one person (and a deleted reddit post on exaltbeta) have an issue when starting the game that said Failed to initialize IL2CPP. Unfortunately I couldn’t get details about their system specs, if I do I’ll add more info here.

Google provides these tutorials which have 3 suggested fixes to the problem.


I’m hesitant to add anything to the guide relating to it yet, just because after looking into it I haven’t seen anyone confirm that a fix worked for them relating to the issue.
Additionally, I don’t believe the initialization and functioning of IL2CPP would be reliant on one’s graphics card or DirectX level at all. I feel like Google is simply confounding “IL2CPP is related to Unity” and “Failed to initialize [something related to Unity]”. (I could always be wrong, maybe it is for some reason GPU-reliant because it does some wacky thing, but I highly doubt it).

As always, if anyone ran into this problem on their end and managed to find a way to fix it, can share and I can look into adding it into the guide.


I don’t know what the error means either, I’ll update if the fixes work for them.


try to open a shortcut within the exalt data folder or directly move Exalt into the data and leave a shortcut in the Production foler


I found a fix for this issue that sometimes appears for Macs (I’m not sure if this issue is on Windows) where items and in game portraits don’t load as seen here:

The fix is to change the game resolution in settings and toggle to not fullscreen. Although you can change it back to fullscreen after.

Trivial Issues Thread

After you change the game resolution and toggle fullscreen, does it fix permanently? Or do you need to do it every time you launch up the game? Just want to make sure I understand completely.


How does one get a name on exalt?


I see that on launch on Mac. It only occurs on first load, so if I do any of change char/go to vault/go to tinkerer/enter Realm it goes away. Normally the first thing I want to do is one of those things, so I am used to now putting up with it for a few seconds.


I fixed it for a friend by doing that, but there are probably more convenient fixes like what Skandling said.