Exalt Technical Problems Troubleshooting Guide


mate is it that hard to make an alt ;-;


I have unnamed mules that can’t trsde


I think it might be broken for unnamed non-Steam accounts tbh, might need to contact support. I assume the issue is you click the name button and nothing happens, and that you made the unnamed accounts a long time ago before the Flash client forced you to name new accounts (~1 year ago).


I’ve been seeing a lot of posts today regarding errors with “load init data” and “Steam authorization error”, and it looks like these same people are reporting that the site is down as well, despite the site working fine for me and many others.

My first assumption is there is a DNS issue somewhere and this is causing players to be unable to access the RotMG site/domain (which leads to the error when attempting to load the game, because it does need to send a request to confirm your login information).
I wonder if this is out of anyone’s hands or if it is an accidental error on Deca’s end. I kind of slept through my networking class because the pandemic hit halfway through it so yep


I had the “load init data” problem yesterday, and it seemed to coincide with https://www.realmofthemadgod.com being down. There was nothing wrong with my internet otherwise, just that site was unreachable, which I discovered as I was looking to download it again to see if that helped.

It fixed itself in about an hour, and I have not seen the problem since. So it seems like a temporary problem, maybe DNS or a problem at their end. Of course it’s also one more problem with the pointless and badly written launcher. Fine, let it dial home for news, updates. But if it can’t connect to the server just let us play the game.


I literally just had that happen right now lol… and after closing/reopening the launcher (a few times) it fixed by itself :man_shrugging:

I used isitdownrightnow.com to check if realmofthemadgod.com was down but it wasn’t, if that helps


yo why my tablet small image


I think that’s called a phone


I’ve made a fairly major update to the guide thanks to information from @Zquidx who helped to test and find increases in performance.

Basically, if you run into the tree lag issue or game crashing on startup, it may be fixable via switching to Intel integrated graphics if you have that available.

I assume the issue in both cases is with the shader Exalt uses to render the outline shadows around things. I don’t exactly know which shader causes the issue for the game crashing though so I could be wrong about this, but I’m hoping that it is in fact that same shader, as it seems the integrated card either just doesn’t load the shader or loads it improperly and either way handles it well enough that the game can actually run and not lag.
Don’t know if Deca can fix this issue as Unity has good amount of issues with compatibility for AMD cards to begin with.


you went in a portal while activating it



Can anyone help with this issue I tried doing what it said searching up about it but I can’t find anything that works I uninstall and reinstall I remove the build then try again and it hasn’t worked for two days so if anyone has any way to solve it please help?


did you delete the game files or go to settings icon in the top corner then remove build? Every time I went through the setting icon, it started working again


yes, I have done that like 10 times each, and still the same.


Additional Solution for the issue: "Build not exist in the current location. You need to download build again"

This fix is Confirmed working for STEAM CONNECTED ACCOUNTS, where the game is being launched from the steam user interface. It also fixed the issue for my friend’s account who does not have a steam account associated with their ign but ymmv.

  1. Navigate to C:\Users\YourUserName\Documents\RealmOfTheMadGod\Production
  2. Right click “ROTMG Exalt.exe
  3. Click on “Properties
  4. Click on the tab labeled “Compatibility
  5. Uncheck the line at the bottom under "Privelege Level", so that "Run this program as administrator" is NOT enabled.

Restart the launcher and everything should load up fine. Keep in mind that the only reason this box would ever be ticked in the first place is because the end user ticked it. I’d assume a lot of people would attempt to “run as admin” when first troubleshooting other issues, so double check that it’s not enabled before attempting further options!


I confirmed that the build error occurs if the Run this program as administrator is checked. Thanks! I’ll add it to the guide.


Hey just a note. I removed the folder with the name Realmofthemadgod but am now running into the issue that there seems to be 0 way of getting that folder back. Help would be appreciated.


Re-installing the launcher should allow you to get it back. If need be, use the uninstaller, then re-install.


Just to note that the AMD fix for intel computers also works for intel computers with NVIDIA (at least for NVIDIA GEFORCE 940mx, laptop).
My i5 3.1Ghz 8Gb Ram computer had lag spikes a bit everywhere. Lag started, processor would go to the moon and after around 5 seconds things would go back to normal.
Setting the intel graphics card to do all the work apparently fixed the issue.


As of 2021-03-02 Patch - Security update, “There is now an option to turn off Shadow rendering in options menu to increase performance”".

Trees (such as the decorative trees in Haunted Cemetery and in Candyland Hunting Grounds) severely lag Exalt
Fix: Options→Video→Quality→Draw Gameview Shadows: Off, Draw GUI Shadows: Off.
Computer\HKEY_CURRENT_USER\SOFTWARE\DECA Live Operations GmbH\RotMGExalt\drawShadows 0

This fixes tree framerate but not drunkenness framerate. I’m on a Dell Latitude e6410, Windows 10 20H2