Exalt update bug


So I like playing rotmg on my free time and i acctualy like the new exalt launcher but recently there have been so many issues i had with it. The most recent one that i cant seem to figure out.
So i started my game as usual and the client updated but when i launched the game I got a message “Client version: x34.2.0. You need to update client via launcher”. I use a mac, tried reinstalling the game, didnt work.

Client Update Needed

Same for me… using Windows.

So I cannot play until this is fixed. So i’ll go for a walk now.


Glad to see im not the only one


Having the same problem with steam exalt and flash


For me it worked again on some servers (USW3, EUSW), on others not (EUW).


me too


yep same thing. uninstalled and everything. hope this gets worked out soon.


Try this proposed workaround from reddit.
Didn’t work for me but you might have better luck.


Ye i get the problem allready, that the client automaticaly connects to your last server. That fix should work for everyone using Windows


again, it happened. editing in regedit does not solve it. And this time I’m not able to change the server.

Don’t do they testings before they bring up a new version?? I work as an software developer. If I would go live with such errors, I would not be a software developer anymore.


Yeah can confirm :d


Time to get 0 fps on flash I guess…


It’s fixed now


Nope. Still getting the “download new launcher” error.


close launcher and open it back, make sure to update if on steam, redownload manually if on standalone


Done already.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.