FIXED: Realm of the Mad God Exalt 1.3.3.1 Nexus button disconnect


#1

Update: FIXED IN ROTMG 1.4.0.0

Hey folks,

Just cross-posting this Lutris thread. Sadly RotMG 1.3.3.1 seems to have broken my Lutris Linux install. If anyone here is playing on Linux could you let me know if you’re having similar issues or if you have a working setup (and if you have a working setup, what it is)?

To summarize, basically the big backend security changes in 1.3.3.1 caused an issue on Linux (Wine) where often when you hit the Nexus key you will disconnect from the game rather than Nexusing. Working around this by hitting Change Server causes FPS drops and, obviously, the server change teleport cooldown.

Obviously Deca can’t officially support Linux but they’ve said they’ll keep an eye on the issue in case a future patch changes the status quo or we get a Wine patch that fixes it, I’ll try and test it on vanilla Wine soon and get a Wine bug report up if it’s not working there.


#2

Forgive my off-topic comment, but that’s the first time that I’ve actually seen another website use the same forums format as here lol


Also, Linux, hm? That’s a name I haven’t heard of in a long time. I wonder how many people still use that?


#3

It’s the same on ubuntu 20.04 with wine 5.5. My workaround is to click on the nexus button below the minimap once the nexus key dcd me. But sometimes that won’t work either.


#4

The format’s actually very common! Example of one I frequent along with RealmEye: https://forums.eveonline.com/

Not a lot for sure, but quite a few, as far as I’ve seen. It’s more secure, it’s open source, it’s free, places like Ask Ubuntu provide awesome support, plus it allows a lot of customizing. Biggest reason it’s still hanging around is because the Windows command prompt is a joke, and there are so many libraries made natively for Linux. Rise from the dust, UNIX gang.


#5

I use GNU/Linux on my main desktop and this issue occurs for me too. Worth noting I am using Steam’s Proton not vanilla Wine. The only difference is I do not experience the frame drops on switching servers, just the disconnection from the server. I haven’t done much looking into it yet, as it hasn’t impeded me too much as of right now.


#6

This is not just on Linux though. People on Mac & Windows are seeing similar disconnects.

Or more precisely what seems to be happening is often when you are disconnected from the game because of starting playing, changing server, going to nexus, even leaving a dungeon, the game often has releatedproblems connecting. I see multiple retries, where the four diamond animation stops then starts again, taking up to a minute, before I see any dialogs.

It seems to especially happen when a Realm is closed, trying to leave a dungeon. Even if you leave plenty of time it can fail to connect. Changing server is another, even when servers are not at all busy (and if they were you would expect to be put in a queue).


#7

While related, I do not see others I play with complaining or experiencing this specific issue unless they are running it under Wine consistently (I will get to that later). I have seen many players (including myself) normally get multiple retries, or have issues with infinite loading when they nexus out of a closed realm (or in Oryx’s Castle) as you mentioned. However, your description of these things doesn’t really line up with this issue. This happens almost (I would drop the ‘almost’, but maybe it worked once out of the 10’s, 100’s of times I’ve tried to nexus since the update) every single time in any portal when trying to escape to the nexus with no loading screen. As seen in the video, you are simply disconnecting and the client keeps extrapolating the movement of players and entities waiting for the server to update them. I have seen these issues before, I’m sure everyone playing the game has at some point, but under Wine now (at least for me, and what it would seem for OP as well) this is near 100% consistently the situation you end up in trying to nexus.


#8

It’s called Discourse. It’s open source forum software.


#9

Yes! I remember the early conversation around the post-founding of these Realmeye forums. I merely haven’t seen it elsewhere. Not that I’ve made a concerted effort to do that, mind you.


#10

I’m also seeing these disconnects (Ubuntu 20.04, wine 5.0, Steam Proton 5.0). Switching servers has been my workaround; no FPS drops, probably thanks to Proton. I encountered a similar bug during early Exalt releases but didn’t report it at the time; the issue was resolved by a subsequent update. Unfortunately I don’t recall which.


#11

absolutely nothing to do with linux and everything to do with Deca’s terrible server management.


#12

After the most recent update I am no longer experiencing this issue running through latest version of Proton available on Steam. Awesome that this has been resolved for me and makes the gameplay experience much more enjoyable not having to switch servers anytime I need to nexus (Especially when I need to hop to a different realm on the same server!). Can anyone else who was experiencing this confirm they no longer get these issues?


#13

FIXED IN 1.4.0.0

Deca must have changed something related to this issue because I now no longer have it!!! :tada::tada::tada::tada::tada::tada: