Problem with loading and playing the game


Hello all!

I seem to have a problem loading and joining the game. I normally play through my Steam account. This problem roughly started a few hours ago. The first instance of this issue was when I attempted to join a different server while in game.

On Exalt, I would get an infinite loading screen and finalizing with the “an existing connection was forcibly closed by the remote host (002).” If I were to load it through Flash, I would just get redirected back to the character screen upon pressing the “Play” button.
This problem only affects my Steam account. When hopping onto another account using the Flash Player, everything is fine.

I have tried the following:

  1. Reinstalling the game
  2. Reinstalling Steam
  3. Using a registry cleaner as suggested by others
  4. Waiting for a while before opening the game
  5. Restarting the computer

Any help in this matter would be appreciated!


Change your server


Thank you for your response.

I should have clarified in my initial message, because changing the server does not help if I can’t join any of them in the first place.



I can’t seem to edit the master post, but I have tried other means to solve this matter. All these options seems to not work:

  1. Attempting to change the server before joining/playing the game
  2. wait for a while before restarting the game or simple just restarting the client
  3. System restore to an earlier date before this problem started

Could this be something with my computer? I normally keep all my apps, namely Google Chrome and Windows, up to date. Or, is it something that has to do with my account? My Steam account?

I really am unsure at this point…


I believe this glitch fixes on its own. I had this glitch and after a few hours later the game went back to normal and I could play again.


Thank you for your response.

Indeed, it seems like this problem got “fixed” on its own. I was suddenly able to go into the Nexus again. I wish I had more information on what I did though.


It actually feels to me like a really funky 10 min dc.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.