Getting really pissed here (move to WC, just need to vent)


I just need to to a little venting here. For the past few weeks, my nexus key has been a little buggy, usually had to press my key around 10 times to actually nexus, without lag mind you. Then came today, I was in a nest, a bee sat on me, spammed my key, didn’t nexus. I didn’t die either, so I figured I’d continue. We found the beekeeper and started to fight. I started getting hit, so me on a priest, I used my tome. But I noticed that my hp didn’t get restored, but my mana was used. I wasn’t sick, so I tried again, same thing, mana went down, hp didn’t go up. I ended up spamming my tome until I didn’t have enough mana, not a single point of hp was restored and my priest ended up dying cause I couldn’t nexus either. This was all done with about 80 memory and 5 net jitter. I had no lag at all, or at least wasn’t experiencing any, and yet the two most vital parts of my character, its tome, and ability to nexus, were taken away from me. Again, please move this to the WC as this wasn’t meant to be super serious, just needed to do a little venting.

Edit; For those saying this was completely my fault, yes I agree with you. I never said it WASN’T my fault, I was just sharing a bug that unfortunately happened to me, I think this is the second time, the first being when my skull stopped working for a brief period a while ago, didn’t die though. And again, no lag was present, I genuinely believe it was something with the game.


Actually I moved this to WC, then I read it and it should probably go in bugs


It’s your fault you died, since you kept pushing forward even after noticing something was wrong, but this is still an annoying problem nonetheless.

I think this might be the server acting up and deciding to ignore some of your inputs, but it’s really weird that it didn’t boot you out of the game when you started spamming your ability. Normally this would get you dc’d, not dead.


is it the game problem or is it your computer? have you tried using a different nexus key or a different key board.

Does manually pressing the nexus button work?

But yeah its kinda your fault for playing, i at least wouldn’t do anything that needed an immediate nexus.


I thought you already vented to me :C


It sucks that you died over stupid shit, but unfortunately it is your fault since you should of exited out of the game instead of moving forward after the problem started.


@moderators please put this in whine celler.


you don’t need to ping moderators for something trivial as that, just let your resident regs move it

also doesnt really seem like a rant, more like an issue so I agree with nameness




yeah there’s a pretty big difference between this post and your typical WC post

As starwar said, this isn’t a “Deca I dead to lag, revive or I’ll quit!!!” this post was respectable and posed a problem instead of just complaining about his death. so this post is perfectly fine imo.


i’ve got that.


change the nexus and ability key?


Happens to me sometime is just Alt+F4 and close the game ,closest thing to nexusing i can get.


Just to make sure, you weren’t sick when you spammed your tome, right?


So let me get this straight, it recognized you shooting (left mouse click) but it didn’t recognize OTHER buttons? Hmm… Some Illuminati shit right there. R.I.P man. I recently lost my 8/8 Priest so I know the pain.


On what you play tho? Kongregate? Steam?


There is no enemy in the Nest that’s capable of inflicting Sick.
The closest you can get is Blue Bees inflicting both Pet Stasis and Quiet.

That’s an extremely odd phenomenon. If possible, would you be able to record yourself in your vault attempting to heal yourself, to see if that works there, at the very least?
Just dequip your pet, and switch off a health-boosting ring, then on again.


Give this a shot.


This sounds somewhat similar to black tiling when there’s server lag; damage is delayed and net jitter is usually not a good indicator of the seriousness of the lag. It could have been that the servers were really bad and the timings of your heals were delayed, so you were essentially healing while full HP as the damage caught up to you.

But at the same time you said mp went down as you pressed space…so I’m not sure. I had a similar thing happen where I was armour broken in oryx castle for like 20 seconds because of the lag, didn’t realize and took a full orange quiet + weak bomb. Needless to say was super sketched seeing purple 20’s above me but I backed out and didn’t nexus, damage actually registered like 10 seconds later.

Perhaps you’d be interesting in Jaki’s terminate rotmg script? I use it a lot when I know nexus won’t work.

Edit: @JimdaFish wow ninjad


LuL dOeSnT eVeN hAvE 10 CpS wHaT a NoOb xDddDDdDDdd

yeah no but seriously this looks like some serious bug