Mac problem with load init data



I have the latest version of macOs, and it will not load RotMG Exalt. Upon booting the launcher it goes straight to error, “problem with load init data”. I have tried for months to get this to work with no avail. I have uninstalled, reinstalled, tweaked firewall, reset pc, etc. I really would like to play the game; please help! I can provide more information if needed!

Thanks, ChickenCho


Is it a problem installing it or running it?


Googled your error message and found quite a few people with the same issue, most from a couple months ago.

Someone was able to fix it by doing this:
“I manually removed the files from my computer to fix this issue - not just uninstalling or removing the build, but going into my Program Files folder (and others) and deleting RotMG files. The error code is supposed to mean that your game files aren’t where they’re supposed to be. They were exactly where they were supposed to be for me, so I got rid of them and then reinstalled and it worked” (Source)

Here’s a video about this issue.

Someone on a Steam discussion thread was able to fix it like this:
" im not sure if anyone is still having this problem, but anyway, if you are. the fix I found is going into the launcher, pressing on the settings button in the top right and then clicking on “remove build” from here, you can then reinstall the build by pressing the play button again and it should work.
open launcher on steam >> click settings >> click remove build >> click play
on a side note, you may have to press play twice as sometimes it doesn’t register." (Source)

Someone else in the same thread got a reply from DECA support with this message and it worked for them:
" Hey guy I just talked with DECA support,and i fixed it you to do following this step first you. *Open regedit (WIN+R, type regedit, hit enter)
*Navigate to ‘Computer\HKEY_CURRENT_USER\Software\DECA Live Operations GmbH’
*Remove all subfolders EXCEPT for the master folder itself - > DECA Live Operations GmbH"

Have you tried sending a message to DECA’s support team yourself? Goodluck!


The launcher doesn’t even present any buttons other than, “ok” to the error message. I cannot launch or even install the game. I cannot remove the build via the launcher.


I have not had this error but if I did I too would manually remove everything. That includes

  • the launcher, normally in your Applications folder
  • the game folder, which contains the game, the test version if you’ve played it. This is in your home directory. Delete the whole folder
  • in ~/Library/Application Support the following two folders: com.decagames.RealmOfTheMadGodExalt and com.decagames.RealmOfTheMadGodExaltLauncher
  • all preferences in ~/Library/Preferences, so the files com.decagames.RealmOfTheMadGodExalt.plist and

The ~/Library refers to your Library folder, inside your home folder. It is normally invisible but you can show it in the Finder preferences, or open it by typing open ~/Library in the

Deleting them all is safe. You will need to download the Launcher again, but that will then download the game and the other files will be recreated. You will need to login again, and might need to re-enter some settings, but that’s all.


Have you tried going into the settings and selecting “allow download”?


@ChickenCho, I would recommend trying the simpler solutions first.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.